aboutsummaryrefslogtreecommitdiffstats
path: root/anime-face-detector/setup.py
diff options
context:
space:
mode:
authorcarp <25677564+carp@users.noreply.github.com>2020-07-13 13:40:11 -0400
committercarp <25677564+carp@users.noreply.github.com>2020-07-13 13:40:11 -0400
commit50e411320563894d411b0c37d37cb16105a908af (patch)
tree01e1a43e11f9e51cf6a46d9a3d40814b76ad6d7b /anime-face-detector/setup.py
parentf457064bb15a00010959e664492d87f3bfe82537 (diff)
downloadyaoi-communism-50e411320563894d411b0c37d37cb16105a908af.tar.gz
yaoi-communism-50e411320563894d411b0c37d37cb16105a908af.zip
removing submodule
Diffstat (limited to 'anime-face-detector/setup.py')
-rw-r--r--anime-face-detector/setup.py42
1 files changed, 0 insertions, 42 deletions
diff --git a/anime-face-detector/setup.py b/anime-face-detector/setup.py
deleted file mode 100644
index dc634f5..0000000
--- a/anime-face-detector/setup.py
+++ /dev/null
@@ -1,42 +0,0 @@
-# --------------------------------------------------------
-# Fast R-CNN
-# Copyright (c) 2015 Microsoft
-# Licensed under The MIT License [see LICENSE for details]
-# Written by Ross Girshick
-# --------------------------------------------------------
-
-import os
-from os.path import join as pjoin
-import numpy as np
-from distutils.core import setup
-from distutils.extension import Extension
-from Cython.Distutils import build_ext
-import sys
-
-
-# Obtain the numpy include directory. This logic works across numpy versions.
-try:
- numpy_include = np.get_include()
-except AttributeError:
- numpy_include = np.get_numpy_include()
-
-# run the customize_compiler
-class custom_build_ext(build_ext):
- def build_extensions(self):
- build_ext.build_extensions(self)
-
-ext_modules = [
- Extension(
- "nms.cpu_nms",
- ["nms/cpu_nms.pyx"],
- extra_compile_args=["-Wno-cpp", "-Wno-unused-function"] if sys.platform == 'linux' else [],
- include_dirs = [numpy_include]
- )
-]
-
-setup(
- name='tf_faster_rcnn',
- ext_modules=ext_modules,
- # inject our custom trigger
- cmdclass={'build_ext': custom_build_ext},
-)